summaryrefslogtreecommitdiff
path: root/nixosConfigurations/manwe/webserver.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixosConfigurations/manwe/webserver.nix')
-rw-r--r--nixosConfigurations/manwe/webserver.nix36
1 files changed, 24 insertions, 12 deletions
diff --git a/nixosConfigurations/manwe/webserver.nix b/nixosConfigurations/manwe/webserver.nix
index d0784e8..95a0b0b 100644
--- a/nixosConfigurations/manwe/webserver.nix
+++ b/nixosConfigurations/manwe/webserver.nix
@@ -5,10 +5,12 @@
libPlausible,
...
}:
-with lib; {
+with lib;
+{
nixfiles.modules.nginx = {
enable = true;
- virtualHosts = with my.domain;
+ virtualHosts =
+ with my.domain;
{
# TODO Start using this.
# "start.local" = {
@@ -78,20 +80,30 @@ with lib; {
"git.${shire}".locations."/".return = "301 https://git.${azahi}";
"bitwarden.${shire}".locations."/".return = "301 https://vaultwarden.${shire}";
${azahi} = {
- serverAliases = ["frodo.${gondor}" "frodo.${rohan}"];
+ serverAliases = [
+ "frodo.${gondor}"
+ "frodo.${rohan}"
+ ];
locations."/" = {
root = inputs.azahi-cc;
- extraConfig = libNginx.config.appendHead [
- (libPlausible.htmlPlausibleScript {domain = azahi;})
- ];
+ extraConfig = libNginx.config.appendHead [ (libPlausible.htmlPlausibleScript { domain = azahi; }) ];
};
};
}
- // (let
- frodo = "301 https://frodo.";
- in {
- ${gondor}.locations."/".return = concatStrings [frodo gondor];
- ${rohan}.locations."/".return = concatStrings [frodo rohan];
- });
+ // (
+ let
+ frodo = "301 https://frodo.";
+ in
+ {
+ ${gondor}.locations."/".return = concatStrings [
+ frodo
+ gondor
+ ];
+ ${rohan}.locations."/".return = concatStrings [
+ frodo
+ rohan
+ ];
+ }
+ );
};
}