about summary refs log tree commit diff
path: root/overlay.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--overlay.nix (renamed from overlays.nix)40
1 files changed, 27 insertions, 13 deletions
diff --git a/overlays.nix b/overlay.nix
index 7229f42..b8e8807 100644
--- a/overlays.nix
+++ b/overlay.nix
@@ -23,7 +23,7 @@ final: prev: {
     preFixup = null;
   });
 
-  grc = prev.grc.overrideAttrs (_: _: {
+  grc = prev.grc.overrideAttrs (_: super: {
     version = "unstable-2021-08-12";
     src = final.fetchFromGitHub {
       owner = "garabik";
@@ -31,37 +31,51 @@ final: prev: {
       rev = "4d6a51fd78ad7e19af8dd12b2a828d1807267079";
       hash = "sha256-SmOZrgV0lgLryFoxADU15IKJ7jhxXar0MgbsV/z1GaE=";
     };
-    patches = [
-      (final.fetchpatch {
-        url = "https://patch-diff.githubusercontent.com/raw/garabik/grc/pull/214.patch";
-        hash = "sha256-VNr9jl5oFbFNJbGsjflwFV3oTbCzJ0lBIZA4eyeoXLY=";
-      })
-    ];
+    patches =
+      (super.patches or [])
+      ++ [
+        (final.fetchpatch {
+          url = "https://patch-diff.githubusercontent.com/raw/garabik/grc/pull/214.patch";
+          hash = "sha256-VNr9jl5oFbFNJbGsjflwFV3oTbCzJ0lBIZA4eyeoXLY=";
+        })
+      ];
   });
 
   alejandra = prev.alejandra.overrideAttrs (_: super: {
-    patches = super.patches ++ [./patches/alejandra-no-noise.patch];
+    patches =
+      (super.patches or [])
+      ++ [
+        ./patches/alejandra-no-noise.patch
+      ];
   });
 
   prismlauncher-unwrapped =
     (prev.prismlauncher-unwrapped.override (finalAttrs: {
-      stdenv = final.useMoldLinker finalAttrs.stdenv;
+      stdenv = final.useMoldLinker (final.impureUseNativeOptimizations finalAttrs.stdenv);
     }))
     .overrideAttrs (_: super: {
-      patches = super.patches ++ [./patches/prismlauncher-allow-offline-accounts.patch];
+      patches =
+        (super.patches or [])
+        ++ [
+          ./patches/prismlauncher-allow-offline-accounts.patch
+        ];
     });
 
   telegram-desktop =
     (prev.telegram-desktop.override (finalAttrs: {
-      stdenv = final.useMoldLinker finalAttrs.stdenv;
+      stdenv = final.useMoldLinker (final.impureUseNativeOptimizations finalAttrs.stdenv);
     }))
     .overrideAttrs (_: super: {
-      patches = super.patches ++ [./patches/telegram-desktop-no-ads.patch];
+      patches =
+        (super.patches or [])
+        ++ [
+          ./patches/telegram-desktop-no-ads.patch
+        ];
     });
 
   vesktop = prev.vesktop.overrideAttrs (_: super: {
     nativeBuildInputs = super.nativeBuildInputs ++ [final.imagemagick];
-    patches = super.patches ++ [./patches/vesktop-no-anime.patch];
+    patches = (super.patches or []) ++ [./patches/vesktop-no-anime.patch];
     postInstall = ''
       rm -rf $out/share/icons/hicolor/*
       for size in 16 24 32 48 64 96; do

Consider giving Nix/NixOS a try! <3