about summary refs log tree commit diff
path: root/overlays.nix
diff options
context:
space:
mode:
Diffstat (limited to 'overlays.nix')
-rw-r--r--overlays.nix44
1 files changed, 22 insertions, 22 deletions
diff --git a/overlays.nix b/overlays.nix
index 18fe174..da6161a 100644
--- a/overlays.nix
+++ b/overlays.nix
@@ -6,7 +6,7 @@
 {
   default =
     final: prev:
-    lib.infuse.v1.infuse prev {
+    lib.infuse prev {
       bruh = _: prev.callPackage ./packages/bruh.nix { };
 
       emacsql-sqlite = _: prev.callPackage ./packages/emacsql-sqlite.nix { };
@@ -63,27 +63,27 @@
 
       openssl_1_0_0 = _: prev.callPackage ./packages/openssl_1_0_0.nix { };
 
-      telegram-desktop = {
-        __input.stdenv = stdenv: final.useMoldLinker stdenv;
-        __output.patches.__append =
-          let
-            patches = "https://raw.githubusercontent.com/msva/mva-overlay/4c89938831bcce03fae22081809e53a47bdee31b/net-im/telegram-desktop/files/patches/0/conditional";
-          in
-          [
-            (prev.fetchpatch {
-              url = "${patches}/tdesktop_patches_hide-sponsored-messages/0000-data_data_sponsored_messages.cpp.patch";
-              hash = "sha256-vVucKG0YNY41MVdqibhKfxL/2/nNPPtYw+otwat971U=";
-            })
-            (prev.fetchpatch {
-              url = "${patches}/tdesktop_patches_allow-disable-stories/option-to-disable-stories.patch";
-              hash = "sha256-ctL9wIn3cLtqgCcQFNnx7WQuBw+9IjDlMJUicmVt8no=";
-            })
-            (prev.fetchpatch {
-              url = "${patches}/tdesktop_patches_hide-banned/0000_hide-messages-from-blocked-users.patch";
-              hash = "sha256-61U3wQsUdLvB4ymHPjVecw9WvhW8W/V0Jf1cnvYUkHk=";
-            })
-          ];
-      };
+      # telegram-desktop = {
+      #   __input.stdenv = stdenv: final.useMoldLinker stdenv;
+      #   __output.patches.__append =
+      #     let
+      #       patches = "https://raw.githubusercontent.com/msva/mva-overlay/4c89938831bcce03fae22081809e53a47bdee31b/net-im/telegram-desktop/files/patches/0/conditional";
+      #     in
+      #     [
+      #       (prev.fetchpatch {
+      #         url = "${patches}/tdesktop_patches_hide-sponsored-messages/0000-data_data_sponsored_messages.cpp.patch";
+      #         hash = "sha256-vVucKG0YNY41MVdqibhKfxL/2/nNPPtYw+otwat971U=";
+      #       })
+      #       (prev.fetchpatch {
+      #         url = "${patches}/tdesktop_patches_allow-disable-stories/option-to-disable-stories.patch";
+      #         hash = "sha256-ctL9wIn3cLtqgCcQFNnx7WQuBw+9IjDlMJUicmVt8no=";
+      #       })
+      #       (prev.fetchpatch {
+      #         url = "${patches}/tdesktop_patches_hide-banned/0000_hide-messages-from-blocked-users.patch";
+      #         hash = "sha256-61U3wQsUdLvB4ymHPjVecw9WvhW8W/V0Jf1cnvYUkHk=";
+      #       })
+      #     ];
+      # };
 
       vesktop = {
         __input = {

Consider giving Nix/NixOS a try! <3