about summary refs log tree commit diff
path: root/packages/bruh.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--packages/bruh.nix25
1 files changed, 17 insertions, 8 deletions
diff --git a/packages/bruh.nix b/packages/bruh.nix
index 62fe557..2b274f1 100644
--- a/packages/bruh.nix
+++ b/packages/bruh.nix
@@ -1,18 +1,20 @@
 {
   alsa-utils,
   fetchFromGitHub,
+  lib,
   stdenv,
 }:
-stdenv.mkDerivation rec {
+stdenv.mkDerivation (finalAttrs: {
   pname = "bruh";
   version = "2.1";
 
-  src = fetchFromGitHub {
-    owner = "kejpies";
-    repo = pname;
-    rev = version;
-    hash = "sha256-Uw6Qes0IZkkfBchFnvnX9l1ZG5T5pyExmV7yUJLPOJ0=";
-  };
+  src = with finalAttrs;
+    fetchFromGitHub {
+      owner = "kejpies";
+      repo = pname;
+      rev = version;
+      hash = "sha256-Uw6Qes0IZkkfBchFnvnX9l1ZG5T5pyExmV7yUJLPOJ0=";
+    };
 
   postPatch = ''
     substituteInPlace bruh.c \
@@ -20,4 +22,11 @@ stdenv.mkDerivation rec {
   '';
 
   makeFlags = ["PREFIX=$(out)"];
-}
+
+  meta = with lib; {
+    description = "Bruh sound, but as a program";
+    inherit (finalAttrs.src.meta) homepage;
+    license = licenses.gpl3Only;
+    maintainers = with maintainers; [azahi];
+  };
+})

Consider giving Nix/NixOS a try! <3