summaryrefslogtreecommitdiff
path: root/packages/lampray.nix
diff options
context:
space:
mode:
Diffstat (limited to 'packages/lampray.nix')
-rw-r--r--packages/lampray.nix58
1 files changed, 58 insertions, 0 deletions
diff --git a/packages/lampray.nix b/packages/lampray.nix
new file mode 100644
index 0000000..876bf60
--- /dev/null
+++ b/packages/lampray.nix
@@ -0,0 +1,58 @@
+{
+ SDL2,
+ autoPatchelfHook,
+ cmake,
+ curl,
+ fetchFromGitHub,
+ lib,
+ lz4,
+ ninja,
+ pkg-config,
+ stdenv,
+}:
+stdenv.mkDerivation {
+ pname = "lampray";
+ version = "1.4.0-unstable-2024-05-25";
+
+ src = fetchFromGitHub {
+ owner = "CHollingworth";
+ repo = "Lampray";
+ rev = "c549fbfbd6ad18b2eca0a6d17b6066d1f74c54b7";
+ hash = "sha256-tjFxHU2kFS5yX0itm4rGKLE7lm/NMgsRjTEGykJELv8=";
+ };
+
+ nativeBuildInputs = [
+ autoPatchelfHook
+ cmake
+ ninja
+ pkg-config
+ ];
+
+ buildInputs = [
+ SDL2
+ curl
+ lz4
+ ];
+
+ installPhase = ''
+ runHook preInstall
+
+ install -Dm755 Lampray $out/bin/lampray
+
+ runHook postInstall
+ '';
+
+ meta = with lib; {
+ description = "Mod manager for gaming on Linux";
+ homepage = "https://github.com/CHollingworth/Lampray";
+ license = with licenses; [
+ unlicense
+ mpl20 # bit7z
+ mit # json & pugixml
+ bsd2 # l4z
+ gpl2Only # l4z
+ ];
+ platforms = [ "x86_64-linux" ];
+ maintainers = with maintainers; [ azahi ];
+ };
+}