summaryrefslogtreecommitdiff
path: root/packages/throttled.nix
diff options
context:
space:
mode:
Diffstat (limited to 'packages/throttled.nix')
-rw-r--r--packages/throttled.nix14
1 files changed, 7 insertions, 7 deletions
diff --git a/packages/throttled.nix b/packages/throttled.nix
index ff896cf..1c0f853 100644
--- a/packages/throttled.nix
+++ b/packages/throttled.nix
@@ -1,25 +1,25 @@
{
fetchFromGitHub,
kmod,
- python3,
+ python3Packages,
stdenv,
}:
stdenv.mkDerivation rec {
pname = "throttled";
- version = "unstable-2022-06-30";
+ version = "git";
src = fetchFromGitHub {
owner = "erpalma";
repo = pname;
- rev = "ab9641a93a409bdc7fca6889ff23ca5a685e5a77";
- hash = "sha256-Zd+rTsVDkw9mq6k2OkMy+HxyYsl3ADy1fEM/1e/jxAs=";
+ rev = "1dd726672f0b11b813d4c7b63e0157becde7a013";
+ hash = "sha256-0MsPp6y4r/uZB2SplKV+SAiJoxIs2jgOQmQoQQ2ZKwI=";
};
- nativeBuildInputs = with python3.pkgs; [wrapPython];
+ nativeBuildInputs = with python3Packages; [wrapPython];
pythonPath =
- (with python3.pkgs; [configparser dbus-python pygobject3])
- ++ [kmod];
+ [kmod]
+ ++ (with python3Packages; [configparser dbus-python pygobject3]);
installPhase = ''
runHook preInstall