summary refs log tree commit diff
path: root/app-misc/pfetch/pfetch-0.6.0-r1.ebuild
diff options
context:
space:
mode:
authorAzat Bahawi <azahi@teknik.io>2020-08-12 15:03:22 +0300
committerAzat Bahawi <azahi@teknik.io>2020-08-12 15:03:22 +0300
commit0647e9d0a1cd30eec4758bbb5e752a175fcf9631 (patch)
tree52f6a65c19633790280780645e5abbc0615f426a /app-misc/pfetch/pfetch-0.6.0-r1.ebuild
parentDeprecate EAPI 5 and 6 (diff)
app-misc/pfetch: Add live
Diffstat (limited to '')
-rw-r--r--app-misc/pfetch/pfetch-0.6.0-r1.ebuild (renamed from app-misc/pfetch/pfetch-0.6.0.ebuild)17
1 files changed, 14 insertions, 3 deletions
diff --git a/app-misc/pfetch/pfetch-0.6.0.ebuild b/app-misc/pfetch/pfetch-0.6.0-r1.ebuild
index 87fa361..7b0623f 100644
--- a/app-misc/pfetch/pfetch-0.6.0.ebuild
+++ b/app-misc/pfetch/pfetch-0.6.0-r1.ebuild
@@ -3,13 +3,24 @@
 
 EAPI=7
 
+if [[ ${PV} == *9999 ]]; then
+	inherit git-r3
+	EGIT_REPO_URI="https://github.com/dylanaraps/pfetch.git"
+fi
+
 DESCRIPTION="A pretty system information tool written in POSIX sh."
 HOMEPAGE="https://github.com/dylanaraps/pfetch"
-SRC_URI="https://github.com/dylanaraps/pfetch/archive/${PV}.tar.gz"
+
+if [[ ${PV} == *9999 ]]; then
+	SRC_URI=""
+	KEYWORDS=""
+else
+	SRC_URI="https://github.com/dylanaraps/pfetch/archive/${PV}.tar.gz -> ${P}.tar.gz"
+	KEYWORDS="~amd64 ~x86"
+fi
 
 LICENSE="MIT"
 SLOT="0"
-KEYWORDS="~amd64 ~x86"
 IUSE=""
 
 DEPEND=""
@@ -17,5 +28,5 @@ RDEPEND="${DEPEND}"
 BDEPEND=""
 
 src_install() {
-	dobin pfetch
+	dobin ${PN}
 }

Consider giving Nix/NixOS a try! <3