summary refs log tree commit diff
path: root/app-misc/pfetch/pfetch-9999.ebuild
diff options
context:
space:
mode:
authorAzat Bahawi <azahi@teknik.io>2020-08-12 15:03:22 +0300
committerAzat Bahawi <azahi@teknik.io>2020-08-12 15:03:22 +0300
commit0647e9d0a1cd30eec4758bbb5e752a175fcf9631 (patch)
tree52f6a65c19633790280780645e5abbc0615f426a /app-misc/pfetch/pfetch-9999.ebuild
parentDeprecate EAPI 5 and 6 (diff)
app-misc/pfetch: Add live
Diffstat (limited to '')
-rw-r--r--app-misc/pfetch/pfetch-9999.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/app-misc/pfetch/pfetch-9999.ebuild b/app-misc/pfetch/pfetch-9999.ebuild
new file mode 100644
index 0000000..7b0623f
--- /dev/null
+++ b/app-misc/pfetch/pfetch-9999.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+if [[ ${PV} == *9999 ]]; then
+	inherit git-r3
+	EGIT_REPO_URI="https://github.com/dylanaraps/pfetch.git"
+fi
+
+DESCRIPTION="A pretty system information tool written in POSIX sh."
+HOMEPAGE="https://github.com/dylanaraps/pfetch"
+
+if [[ ${PV} == *9999 ]]; then
+	SRC_URI=""
+	KEYWORDS=""
+else
+	SRC_URI="https://github.com/dylanaraps/pfetch/archive/${PV}.tar.gz -> ${P}.tar.gz"
+	KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+BDEPEND=""
+
+src_install() {
+	dobin ${PN}
+}

Consider giving Nix/NixOS a try! <3