summary refs log tree commit diff
path: root/app-misc/seq2gif/seq2gif-9999.ebuild
diff options
context:
space:
mode:
authorAzat Bahawi <azahi@teknik.io>2020-08-13 15:45:57 +0300
committerAzat Bahawi <azahi@teknik.io>2020-08-13 15:45:57 +0300
commitbc681f2b2f661054eb2bc2e10e26e2597c3ecc95 (patch)
tree6b43d4fee5d19c86a4faa6a4cc6dd48ab4060df3 /app-misc/seq2gif/seq2gif-9999.ebuild
parentRemove unrelated package (diff)
app-misc/seq2gif: Add package
Diffstat (limited to '')
-rw-r--r--app-misc/seq2gif/seq2gif-9999.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/app-misc/seq2gif/seq2gif-9999.ebuild b/app-misc/seq2gif/seq2gif-9999.ebuild
new file mode 100644
index 0000000..0a28691
--- /dev/null
+++ b/app-misc/seq2gif/seq2gif-9999.ebuild
@@ -0,0 +1,50 @@
+# Copyright 2018-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+if [[ ${PV} == *9999 ]]; then
+	SCM="git-r3"
+	EGIT_REPO_URI="https://github.com/saitoha/seq2gif.git"
+fi
+
+inherit eutils autotools ${SCM}
+
+DESCRIPTION="Console-based audio visualizer for ALSA"
+HOMEPAGE="https://github.com/saitoha/seq2gif"
+
+if [[ ${PV} == *9999 ]]; then
+	SRC_URI=""
+	KEYWORDS=""
+else
+	SRC_URI="https://github.com/saitoha/seq2gif/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+	KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+BDEPEND=""
+
+DOCS=( README.md )
+
+src_prepare() {
+	eapply_user
+	eautoreconf
+}
+
+src_configure() {
+	econf
+}
+
+src_compile() {
+	emake
+}
+
+src_install() {
+	einstalldocs
+	emake DESTDIR="${D}" PREFIX=/usr install
+}

Consider giving Nix/NixOS a try! <3