summary refs log tree commit diff
path: root/x11-apps/sx/sx-9999.ebuild
diff options
context:
space:
mode:
authorAzat Bahawi <azahi@teknik.io>2020-08-23 11:38:44 +0300
committerAzat Bahawi <azahi@teknik.io>2020-08-23 11:38:44 +0300
commit385f67fcd5a39c11004627ba48978227bd9f48b2 (patch)
treed9a8e2c1d34c6f43408564fb8eb91c8fd5e2ebe9 /x11-apps/sx/sx-9999.ebuild
parentUpdate TODO.md (diff)
x11-apps/sx: Add package
Diffstat (limited to '')
-rw-r--r--x11-apps/sx/sx-9999.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/x11-apps/sx/sx-9999.ebuild b/x11-apps/sx/sx-9999.ebuild
new file mode 100644
index 0000000..02809d4
--- /dev/null
+++ b/x11-apps/sx/sx-9999.ebuild
@@ -0,0 +1,42 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+if [[ ${PV} == *9999 ]]; then
+	inherit git-r3
+	EGIT_REPO_URI="https://github.com/Earnestly/sx.git"
+fi
+
+DESCRIPTION="A simpler alternative to xinit"
+HOMEPAGE="https://github.com/Earnestly/sx"
+
+if [[ ${PV} == *9999 ]]; then
+	SRC_URI=""
+	KEYWORDS=""
+else
+	SRC_URI="https://github.com/Earnestly/sx/archive/${PV}.tar.gz -> ${P}.tar.gz"
+	KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+DEPEND="
+	x11-apps/xauth
+	x11-base/xorg-server[xorg]
+"
+RDEPEND="${DEPEND}"
+BDEPEND=""
+
+src_compile()
+{
+	true
+}
+
+src_install()
+{
+	dobin ${PN}
+	doman ${PN}.1
+}

Consider giving Nix/NixOS a try! <3