summary refs log tree commit diff
path: root/x11-misc/bgs/bgs-0.8.ebuild
diff options
context:
space:
mode:
authorazahi <azahi@teknik.io>2018-12-28 01:22:40 +0300
committerazahi <azahi@teknik.io>2018-12-28 01:22:40 +0300
commit8f2f466965f061ce6d6be4443497c0fe6e10a5bc (patch)
tree9999239cbbac3bab7497b28c44dd75cf499d7f8c /x11-misc/bgs/bgs-0.8.ebuild
Initial
Diffstat (limited to '')
-rw-r--r--x11-misc/bgs/bgs-0.8.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/x11-misc/bgs/bgs-0.8.ebuild b/x11-misc/bgs/bgs-0.8.ebuild
new file mode 100644
index 0000000..bf7d66b
--- /dev/null
+++ b/x11-misc/bgs/bgs-0.8.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Simple background setter based on imlib2"
+HOMEPAGE="https://github.com/Gottox/bgs"
+SRC_URI="https://github.com/Gottox/bgs/archive/v${PV}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="xinerama"
+
+DEPEND="media-libs/imlib2
+	x11-libs/libX11
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+	default
+
+	sed -e 's/PREFIX = \/usr\/local/PREFIX = \/usr/' -i config.mk || die
+
+	if use xinerama; then
+		sed -e '/XINERAMALIBS/d' -i config.mk || die
+		sed -e '/XINERAMAFLAGS/d' -i config.mk || die
+	fi
+}

Consider giving Nix/NixOS a try! <3