summary refs log tree commit diff
path: root/x11-misc/bgs/bgs-9999.ebuild
diff options
context:
space:
mode:
authorAzat Bahawi <azahi@teknik.io>2020-08-12 14:53:33 +0300
committerAzat Bahawi <azahi@teknik.io>2020-08-12 14:53:33 +0300
commit016e5e230228388fbe9d0326caa476cf6754a0b0 (patch)
tree8e4e9f3024785dce2804095f667742d69c95831c /x11-misc/bgs/bgs-9999.ebuild
parentUpdate README.rst (diff)
x11-misc/bgs: Bump EAPI, Add live
Diffstat (limited to '')
-rw-r--r--x11-misc/bgs/bgs-9999.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/x11-misc/bgs/bgs-9999.ebuild b/x11-misc/bgs/bgs-9999.ebuild
new file mode 100644
index 0000000..a80b487
--- /dev/null
+++ b/x11-misc/bgs/bgs-9999.ebuild
@@ -0,0 +1,44 @@
+# Copyright 2018-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+if [[ ${PV} == *9999 ]]; then
+	inherit git-r3
+	EGIT_REPO_URI="https://github.com/Gottox/bgs"
+fi
+
+DESCRIPTION="Simple background setter based on imlib2"
+HOMEPAGE="https://github.com/Gottox/bgs"
+
+if [[ ${PV} == *9999 ]]; then
+	SRC_URI=""
+	KEYWORDS=""
+else
+	SRC_URI="https://github.com/Gottox/bgs/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+	KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="xinerama"
+
+DEPEND="xinerama? ( x11-libs/libXinerama )
+	media-libs/imlib2
+	x11-libs/libX11
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+	default
+
+	if use xinerama; then
+		sed -e '/XINERAMALIBS/d' -i config.mk || die
+		sed -e '/XINERAMAFLAGS/d' -i config.mk || die
+	fi
+}
+
+src_install() {
+	dobin ${PN}
+	doman ${PN}.1
+}

Consider giving Nix/NixOS a try! <3