summary refs log tree commit diff
path: root/x11-misc/xbanish/xbanish-9999.ebuild
diff options
context:
space:
mode:
authorAzat Bahawi <azahi@teknik.io>2020-10-10 13:18:48 +0300
committerAzat Bahawi <azahi@teknik.io>2020-10-10 13:18:53 +0300
commit437752c632af82403753bddf2a629cc8c4f191e1 (patch)
treeafe0bbfe042ec77f746d08baa5f4e252049d8e90 /x11-misc/xbanish/xbanish-9999.ebuild
parentx11-libs/libwm: Move from category dev-libs (diff)
x11-misc/xbanish: Add package
Package-Manager: Portage-3.0.8, Repoman-3.0.1
Signed-off-by: Azat Bahawi <azahi@teknik.io>
Diffstat (limited to '')
-rw-r--r--x11-misc/xbanish/xbanish-9999.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/x11-misc/xbanish/xbanish-9999.ebuild b/x11-misc/xbanish/xbanish-9999.ebuild
new file mode 100644
index 0000000..844d3aa
--- /dev/null
+++ b/x11-misc/xbanish/xbanish-9999.ebuild
@@ -0,0 +1,40 @@
+# Copyright 2018-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+if [[ ${PV} == *9999 ]]; then
+	inherit git-r3
+	EGIT_REPO_URI="https://github.com/jcs/xbanish.git"
+fi
+
+DESCRIPTION="Banish the mouse cursor when typing, show it again when the mouse moves"
+HOMEPAGE="https://github.com/jcs/xbanish"
+
+if [[ ${PV} == *9999 ]]; then
+	SRC_URI=""
+	KEYWORDS=""
+else
+	SRC_URI="https://github.com/jcs/xbanish/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+	KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+DEPEND="
+	x11-libs/libX11
+	x11-libs/libXfixes
+	x11-libs/libXi
+"
+RDEPEND="${DEPEND}"
+BDEPEND=""
+
+DOCS=( README.md )
+
+src_install() {
+	dobin ${PN}
+	doman ${PN}.1
+	einstalldocs
+}

Consider giving Nix/NixOS a try! <3