summary refs log tree commit diff
path: root/x11-wm/sdorfehs/sdorfehs-9999.ebuild
diff options
context:
space:
mode:
authorAzat Bahawi <azahi@teknik.io>2020-10-10 02:19:07 +0300
committerAzat Bahawi <azahi@teknik.io>2020-10-10 02:19:22 +0300
commitd2547e1d17a37903e816a7603e64e6e9ff55c76a (patch)
tree15356264eaee48cb2016b0b432f1f2f206ae318e /x11-wm/sdorfehs/sdorfehs-9999.ebuild
parentUpdate TODO.md (diff)
x11-wm/sdorfehs: Add package
Package-Manager: Portage-3.0.8, Repoman-3.0.1
Signed-off-by: Azat Bahawi <azahi@teknik.io>
Diffstat (limited to '')
-rw-r--r--x11-wm/sdorfehs/sdorfehs-9999.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/x11-wm/sdorfehs/sdorfehs-9999.ebuild b/x11-wm/sdorfehs/sdorfehs-9999.ebuild
new file mode 100644
index 0000000..591bb39
--- /dev/null
+++ b/x11-wm/sdorfehs/sdorfehs-9999.ebuild
@@ -0,0 +1,48 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+if [[ ${PV} == *9999 ]]; then
+	SCM="git-r3"
+	EGIT_REPO_URI="https://github.com/jcs/sdorfehs.git"
+fi
+
+inherit savedconfig ${SCM}
+
+DESCRIPTION="Manual tiling window manager"
+HOMEPAGE="https://github.com/jcs/sdorfehs"
+
+if [[ ${PV} == *9999 ]]; then
+	SRC_URI=""
+	KEYWORDS=""
+else
+	SRC_URI="https://github.com/jcs/sdorfehs/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+	KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+DEPEND="
+	x11-libs/libX11
+	x11-libs/libXft
+	x11-libs/libXrandr
+	x11-libs/libXtst
+"
+RDEPEND="${DEPEND}"
+BDEPEND=""
+
+DOCS=( README.md )
+
+src_compile() {
+	restore_config config.h
+	default
+}
+
+src_install() {
+	save_config config.h
+	dobin ${PN}
+	doman ${PN}.1
+}

Consider giving Nix/NixOS a try! <3