summary refs log tree commit diff
path: root/x11-wm/shod/shod-0.2.2.ebuild
diff options
context:
space:
mode:
authorAzat Bahawi <azahi@teknik.io>2020-08-10 12:47:44 +0300
committerAzat Bahawi <azahi@teknik.io>2020-08-10 12:47:44 +0300
commit73898779e00760943a34318bd34f7403af12ef73 (patch)
tree04e8a75232b8d6869540f735b4aebbd7d48b673a /x11-wm/shod/shod-0.2.2.ebuild
parentx11-misc/closest: Add package (diff)
x11-wm/shod: Add package
Diffstat (limited to '')
-rw-r--r--x11-wm/shod/shod-0.2.2.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/x11-wm/shod/shod-0.2.2.ebuild b/x11-wm/shod/shod-0.2.2.ebuild
new file mode 100644
index 0000000..cc28c3b
--- /dev/null
+++ b/x11-wm/shod/shod-0.2.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2019-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+if [[ ${PV} == *9999 ]]; then
+	SCM="git-r3"
+	EGIT_REPO_URI="https://github.com/phillbush/shod.git"
+fi
+
+inherit eutils ${SCM}
+
+DESCRIPTION="hybrid (floating and tiling) window manager"
+HOMEPAGE="https://github.com/phillbush/shod"
+
+if [[ ${PV} == *9999 ]]; then
+	SRC_URI=""
+	KEYWORDS=""
+else
+	SRC_URI="https://github.com/phillbush/shod/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+	KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+DEPEND="x11-libs/libX11
+	x11-libs/libXinerama
+"
+RDEPEND="${DEPEND}"
+BDEPEND=""
+
+src_install() {
+	emake PREFIX= DESTDIR="${D}" MANPREFIX="/usr/share/man" install
+}

Consider giving Nix/NixOS a try! <3