summary refs log tree commit diff
path: root/x11-wm/sowm/sowm-9999.ebuild
diff options
context:
space:
mode:
authorAzat Bahawi <azahi@teknik.io>2020-08-17 18:00:49 +0300
committerAzat Bahawi <azahi@teknik.io>2020-08-17 18:00:49 +0300
commit95b0d99756bb10976fa0f33d906a4e3860ee7200 (patch)
tree713b6597dc298ddc023b1dfe3daba6fe28f2300a /x11-wm/sowm/sowm-9999.ebuild
parentx11-wm/tinywm: Add package (diff)
x11-wm/sowm: Add package
Diffstat (limited to '')
-rw-r--r--x11-wm/sowm/sowm-9999.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/x11-wm/sowm/sowm-9999.ebuild b/x11-wm/sowm/sowm-9999.ebuild
new file mode 100644
index 0000000..570763c
--- /dev/null
+++ b/x11-wm/sowm/sowm-9999.ebuild
@@ -0,0 +1,42 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+if [[ ${PV} == *9999 ]]; then
+	SCM="git-r3"
+	EGIT_REPO_URI="https://github.com/dylanaraps/sowm.git"
+fi
+
+inherit savedconfig ${SCM}
+
+DESCRIPTION="An itsy bitsy floating window manager"
+HOMEPAGE="https://github.com/dylanaraps/sowm"
+
+if [[ ${PV} == *9999 ]]; then
+	SRC_URI=""
+	KEYWORDS=""
+else
+	SRC_URI="https://github.com/dylanaraps/sowm/archive/${PV}.tar.gz -> ${P}.tar.gz"
+	KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+DEPEND="x11-libs/libX11"
+RDEPEND="${DEPEND}"
+BDEPEND=""
+
+DOCS=( README.md )
+
+src_compile() {
+	restore_config config.h
+	default
+}
+
+src_install() {
+	save_config config.h
+	default
+}

Consider giving Nix/NixOS a try! <3