summary refs log tree commit diff
path: root/app-misc/afetch/afetch-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/afetch/afetch-9999.ebuild')
-rw-r--r--app-misc/afetch/afetch-9999.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/app-misc/afetch/afetch-9999.ebuild b/app-misc/afetch/afetch-9999.ebuild
new file mode 100644
index 0000000..ca1fc83
--- /dev/null
+++ b/app-misc/afetch/afetch-9999.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+if [[ ${PV} == *9999 ]]; then
+	SCM="git-r3"
+	EGIT_REPO_URI="https://github.com/13-CF/afetch.git"
+fi
+
+inherit savedconfig toolchain-funcs ${SCM}
+
+DESCRIPTION="Simple system info written in C"
+HOMEPAGE="https://github.com/13-CF/afetch"
+
+if [[ ${PV} == *9999 ]]; then
+	SRC_URI=""
+	KEYWORDS=""
+else
+	SRC_URI="https://github.com/13-CF/afetch/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+	KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+BDEPEND=""
+
+DOCS=(README.md)
+
+src_prepare() {
+	sed -e 's/^CFLAGS =/CFLAGS +=/' \
+		-e 's/-O2//g' \
+		-i Makefile || die
+
+	restore_config src/config.h
+
+	default
+}
+
+src_compile() {
+	emake \
+		CC="$(tc-getCC)"
+}
+
+src_install() {
+	save_config src/config.h
+
+	dobin ${PN}
+	doman src/${PN}.1
+}

Consider giving Nix/NixOS a try! <3