summary refs log tree commit diff
path: root/app-misc/fbcat/fbcat-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--app-misc/fbcat/fbcat-9999.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/app-misc/fbcat/fbcat-9999.ebuild b/app-misc/fbcat/fbcat-9999.ebuild
new file mode 100644
index 0000000..6787c18
--- /dev/null
+++ b/app-misc/fbcat/fbcat-9999.ebuild
@@ -0,0 +1,45 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+if [[ ${PV} == *9999 ]]; then
+	inherit git-r3
+	EGIT_REPO_URI="https://github.com/jwilk/fbcat.git"
+fi
+
+DESCRIPTION="Framebuffer grabber"
+HOMEPAGE="https://github.com/jwilk/fbcat"
+
+if [[ ${PV} == *9999 ]]; then
+	SRC_URI=""
+	KEYWORDS=""
+else
+	SRC_URI="https://github.com/jwilk/fbcat/archive/${PV}.tar.gz -> ${P}.tar.gz"
+	KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="doc"
+
+DEPEND=""
+RDEPEND="${DEPEND}
+	media-libs/netpbm
+	sys-apps/kbd
+"
+BDEPEND="
+	doc? (
+		dev-libs/libxslt
+		app-text/docbook-xsl-stylesheets
+	)
+"
+
+src_compile() {
+	default
+	use doc && emake -C doc
+}
+
+src_install() {
+	emake DESTDIR="${D}" PREFIX="/usr" install
+}

Consider giving Nix/NixOS a try! <3