summary refs log tree commit diff
path: root/dev-util/ccls/ccls-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/ccls/ccls-9999.ebuild')
-rw-r--r--dev-util/ccls/ccls-9999.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-util/ccls/ccls-9999.ebuild b/dev-util/ccls/ccls-9999.ebuild
new file mode 100644
index 0000000..8589e0a
--- /dev/null
+++ b/dev-util/ccls/ccls-9999.ebuild
@@ -0,0 +1,29 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake git-r3
+
+DESCRIPTION="C/C++/ObjC language server"
+HOMEPAGE="https://github.com/MaskRay/ccls"
+EGIT_REPO_URI="https://github.com/MaskRay/${PN}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+DEPEND="dev-libs/rapidjson
+	sys-devel/clang:=
+	sys-devel/llvm:=
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+	local mycmakeargs=(
+		-DUSE_SYSTEM_RAPIDJSON=ON
+		-DCLANG_LINK_CLANG_DYLIB=1
+	)
+	cmake_src_configure
+}

Consider giving Nix/NixOS a try! <3