summary refs log tree commit diff
path: root/media-fonts/tewi-font/tewi-font-9999-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'media-fonts/tewi-font/tewi-font-9999-r1.ebuild')
-rw-r--r--media-fonts/tewi-font/tewi-font-9999-r1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/media-fonts/tewi-font/tewi-font-9999-r1.ebuild b/media-fonts/tewi-font/tewi-font-9999-r1.ebuild
new file mode 100644
index 0000000..aa5790c
--- /dev/null
+++ b/media-fonts/tewi-font/tewi-font-9999-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 2018-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+if [[ ${PV} == *9999 ]]; then
+	SCM="git-r3"
+	EGIT_REPO_URI="https://github.com/lucy/tewi-font.git"
+fi
+
+inherit font font-ebdftopcf ${SCM}
+
+DESCRIPTION="A small bitmap font"
+HOMEPAGE="https://github.com/lucy/tewi-font"
+
+if [[ ${PV} == *9999 ]]; then
+	SRC_URI=""
+	KEYWORDS=""
+else
+	SRC_URI="https://github.com/lucy/tewi-font/archive/${PV}.tar.gz -> ${P}.tar.gz"
+	KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+BDEPEND=""
+
+DOCS=( README.md )
+FONT_S=( ${S} ${S}/variant )
+
+src_compile() {
+	font-ebdftopcf_src_compile
+}

Consider giving Nix/NixOS a try! <3