summary refs log tree commit diff
path: root/media-fonts/tewi-font/tewi-font-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'media-fonts/tewi-font/tewi-font-9999.ebuild')
-rw-r--r--media-fonts/tewi-font/tewi-font-9999.ebuild24
1 files changed, 19 insertions, 5 deletions
diff --git a/media-fonts/tewi-font/tewi-font-9999.ebuild b/media-fonts/tewi-font/tewi-font-9999.ebuild
index 60cb553..d8aefb5 100644
--- a/media-fonts/tewi-font/tewi-font-9999.ebuild
+++ b/media-fonts/tewi-font/tewi-font-9999.ebuild
@@ -1,25 +1,39 @@
 # Copyright 2018-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=6
+EAPI=7
 
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+PYTHON_COMPAT=( python3_{6,7,8} )
 
-inherit git-r3 font python-any-r1
+if [[ ${PV} == *9999 ]]; then
+	SCM="git-r3"
+	EGIT_REPO_URI="https://github.com/lucy/tewi-font.git"
+fi
+
+inherit font python-any-r1 ${SCM}
 
 DESCRIPTION="A small bitmap font"
 HOMEPAGE="https://github.com/lucy/tewi-font"
-EGIT_REPO_URI="https://github.com/lucy/tewi-font.git"
+
+if [[ ${PV} == *9999 ]]; then
+	SRC_URI=""
+	KEYWORDS=""
+else
+	SRC_URI="https://github.com/lucy/tewi-font/archive/${PV}.tar.gz -> ${P}.tar.gz"
+	KEYWORDS="~amd64 ~x86"
+fi
 
 LICENSE="MIT"
 SLOT="0"
-KEYWORDS=""
 IUSE="+pcf"
 
 DEPEND="x11-libs/libX11
 	pcf? ( x11-apps/bdftopcf )
 "
 RDEPEND="x11-libs/libX11"
+BDEPEND=""
+
+S="${WORKDIR}/${P}"
 
 src_compile() {
 	if use pcf; then

Consider giving Nix/NixOS a try! <3