summary refs log tree commit diff
path: root/media-gfx/xmcp/xmcp-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--media-gfx/xmcp/xmcp-9999.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/media-gfx/xmcp/xmcp-9999.ebuild b/media-gfx/xmcp/xmcp-9999.ebuild
new file mode 100644
index 0000000..73f50ce
--- /dev/null
+++ b/media-gfx/xmcp/xmcp-9999.ebuild
@@ -0,0 +1,41 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+if [[ ${PV} == *9999 ]]; then
+	SCM="git-r3"
+	EGIT_REPO_URI="https://github.com/0xbiel/xmcp.git"
+fi
+
+inherit toolchain-funcs ${SCM}
+
+DESCRIPTION="Universal color picker"
+HOMEPAGE="https://github.com/0xbiel/xmcp"
+
+if [[ ${PV} == *9999 ]]; then
+	SRC_URI=""
+	KEYWORDS=""
+else
+	SRC_URI="https://github.com/0xbiel/xmcp/archive/${PV}.tar.gz -> ${P}.tar.gz"
+	KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE=""
+
+DEPEND="x11-libs/libX11"
+RDEPEND="${DEPEND}"
+BDEPEND=""
+
+DOCS=( README.md )
+
+src_compile() {
+	$(tc-getCC) -o ${PN} ${PN}.c -lX11 ${CFLAGS} ${LDFLAGS}
+}
+
+src_install() {
+	dobin ${PN}
+	dodoc README.md
+}

Consider giving Nix/NixOS a try! <3