summary refs log tree commit diff
path: root/media-sound/cava/cava-0.7.2-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/cava/cava-0.7.2-r1.ebuild')
-rw-r--r--media-sound/cava/cava-0.7.2-r1.ebuild68
1 files changed, 68 insertions, 0 deletions
diff --git a/media-sound/cava/cava-0.7.2-r1.ebuild b/media-sound/cava/cava-0.7.2-r1.ebuild
new file mode 100644
index 0000000..a91deed
--- /dev/null
+++ b/media-sound/cava/cava-0.7.2-r1.ebuild
@@ -0,0 +1,68 @@
+# Copyright 2018-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+if [[ ${PV} == *9999 ]]; then
+	SCM="git-r3"
+	EGIT_REPO_URI="https://github.com/karlstav/cava.git"
+fi
+
+inherit linux-info eutils autotools ${SCM}
+
+DESCRIPTION="Console-based audio visualizer for ALSA"
+HOMEPAGE="https://github.com/karlstav/cava"
+
+if [[ ${PV} == *9999 ]]; then
+	SRC_URI=""
+	KEYWORDS=""
+else
+	SRC_URI="https://github.com/karlstav/cava/archive/${PV}.tar.gz -> ${P}.tar.gz"
+	KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="alsa debug portaudio pulseaudio system-iniparser"
+
+DEPEND="
+	sci-libs/fftw:3.0
+	sys-libs/ncurses
+	system-iniparser? ( dev-libs/iniparser:4 )
+"
+RDEPEND="${DEPEND}
+	alsa? ( media-libs/alsa-lib )
+	pulseaudio? ( media-sound/pulseaudio )
+	portaudio? ( media-libs/portaudio )
+"
+BDEPEND=""
+
+DOCS=( README.md example_files/ )
+
+CONFIG_CHECK=(
+	SND_ALOOP
+)
+
+src_prepare() {
+	eapply_user
+	eautoreconf
+}
+
+src_configure() {
+	econf \
+		$(use_enable debug) \
+		$(use_enable alsa input-alsa) \
+		$(use_enable pulseaudio input-pulse) \
+		$(use_enable portaudio input-portaudio) \
+		$(use_enable system-iniparser) \
+		--docdir="${EREFIX}/usr/share/doc/${PF}"
+}
+
+src_compile() {
+	emake
+}
+
+src_install() {
+	einstalldocs
+	emake DESTDIR="${D}" PREFIX=/usr install
+}

Consider giving Nix/NixOS a try! <3