summary refs log tree commit diff
path: root/x11-apps/sx/sx-2.1.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--x11-apps/sx/sx-2.1.3.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/x11-apps/sx/sx-2.1.3.ebuild b/x11-apps/sx/sx-2.1.3.ebuild
new file mode 100644
index 0000000..02809d4
--- /dev/null
+++ b/x11-apps/sx/sx-2.1.3.ebuild
@@ -0,0 +1,42 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+if [[ ${PV} == *9999 ]]; then
+	inherit git-r3
+	EGIT_REPO_URI="https://github.com/Earnestly/sx.git"
+fi
+
+DESCRIPTION="A simpler alternative to xinit"
+HOMEPAGE="https://github.com/Earnestly/sx"
+
+if [[ ${PV} == *9999 ]]; then
+	SRC_URI=""
+	KEYWORDS=""
+else
+	SRC_URI="https://github.com/Earnestly/sx/archive/${PV}.tar.gz -> ${P}.tar.gz"
+	KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+DEPEND="
+	x11-apps/xauth
+	x11-base/xorg-server[xorg]
+"
+RDEPEND="${DEPEND}"
+BDEPEND=""
+
+src_compile()
+{
+	true
+}
+
+src_install()
+{
+	dobin ${PN}
+	doman ${PN}.1
+}

Consider giving Nix/NixOS a try! <3