summary refs log tree commit diff
path: root/x11-misc/colt/colt-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--x11-misc/colt/colt-9999.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/x11-misc/colt/colt-9999.ebuild b/x11-misc/colt/colt-9999.ebuild
new file mode 100644
index 0000000..3d9e68b
--- /dev/null
+++ b/x11-misc/colt/colt-9999.ebuild
@@ -0,0 +1,35 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+if [[ ${PV} == *9999 ]]; then
+	inherit git-r3
+	EGIT_REPO_URI="https://github.com/azahi/colt.git"
+fi
+
+DESCRIPTION="A small color temperature and brightness controller for X11."
+HOMEPAGE="https://github.com/azahi/colt"
+
+if [[ ${PV} == *9999 ]]; then
+	SRC_URI=""
+	KEYWORDS=""
+else
+	SRC_URI="https://github.com/azahi/colt/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+	KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="WTFPL-2"
+SLOT="0"
+IUSE=""
+
+DEPEND="x11-libs/libX11
+	x11-libs/libXinerama
+"
+RDEPEND="${DEPEND}"
+BDEPEND=""
+
+src_install ()
+{
+	dobin ${PN}
+}

Consider giving Nix/NixOS a try! <3