summary refs log tree commit diff
path: root/x11-misc/devour/devour-12.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/devour/devour-12.ebuild')
-rw-r--r--x11-misc/devour/devour-12.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/x11-misc/devour/devour-12.ebuild b/x11-misc/devour/devour-12.ebuild
new file mode 100644
index 0000000..2b88b39
--- /dev/null
+++ b/x11-misc/devour/devour-12.ebuild
@@ -0,0 +1,51 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+if [[ ${PV} == *9999 ]]; then
+	SCM="git-r3"
+	EGIT_REPO_URI="https://github.com/salman-abedin/devour.git"
+fi
+
+inherit toolchain-funcs "${SCM}"
+
+DESCRIPTION="Window manager agnostic swallowing feature for terminal emulators"
+HOMEPAGE="https://github.com/salman-abedin/devour"
+
+if [[ ${PV} == *9999 ]]; then
+	SRC_URI=""
+	KEYWORDS=""
+else
+	SRC_URI="https://github.com/salman-abedin/devour/archive/${PV}.tar.gz"
+	KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE=""
+
+DEPEND="x11-libs/libX11"
+RDEPEND="${DEPEND}"
+BDEPEND=""
+
+DOCS=( README.md )
+
+src_prepare() {
+	default
+
+	sed -e 's/^CFLAGS =/CFLAGS +=/' \
+		-e 's/ -s //g' \
+		-e 's/ -O2//g' \
+		-i Makefile || die
+}
+
+src_compile() {
+	emake \
+		CC="$(tc-getCC)"
+}
+
+src_install() {
+	dobin ${PN}
+	einstalldocs
+}

Consider giving Nix/NixOS a try! <3