summary refs log tree commit diff
path: root/x11-misc/herbe/herbe-1.0.0-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--x11-misc/herbe/herbe-1.0.0-r1.ebuild (renamed from x11-misc/herbe/herbe-1.0.0.ebuild)33
1 files changed, 23 insertions, 10 deletions
diff --git a/x11-misc/herbe/herbe-1.0.0.ebuild b/x11-misc/herbe/herbe-1.0.0-r1.ebuild
index 263ceab..bc9427d 100644
--- a/x11-misc/herbe/herbe-1.0.0.ebuild
+++ b/x11-misc/herbe/herbe-1.0.0-r1.ebuild
@@ -3,32 +3,45 @@
 
 EAPI=7
 
-inherit savedconfig
+if [[ ${PV} == *9999 ]]; then
+	SCM="git-r3"
+	EGIT_REPO_URI="https://github.com/dudik/herbe.git"
+fi
 
-DESCRIPTION="Daemon-less notifications without D-Bus. Minimal and lightweight."
+inherit savedconfig ${SCM}
+
+DESCRIPTION="Daemon-less notifications without D-Bus"
 HOMEPAGE="https://github.com/dudik/herbe"
-SRC_URI="https://github.com/dudik/herbe/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+if [[ ${PV} == *9999 ]]; then
+	SRC_URI=""
+	KEYWORDS=""
+else
+	SRC_URI="https://github.com/dudik/herbe/archive/${PV}.tar.gz -> ${P}.tar.gz"
+	KEYWORDS="~amd64 ~x86"
+fi
 
 LICENSE="MIT"
 SLOT="0"
-KEYWORDS="~amd64 ~x86"
 IUSE=""
 
-DEPEND="x11-libs/libX11
-	x11-libs/libXft
+DEPEND="
 	media-libs/freetype:2
+	x11-libs/libX11
+	x11-libs/libXft
 "
 RDEPEND="${DEPEND}"
 BDEPEND=""
 
-src_prepare() {
-	default
+DOCS=( README.md )
 
+src_prepare() {
 	restore_config config.h
+	default
 }
 
 src_install() {
-	emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" install
-
 	save_config config.h
+	emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" install
+	einstalldocs
 }

Consider giving Nix/NixOS a try! <3