summary refs log tree commit diff
path: root/x11-misc/lemonbar/lemonbar-1.4.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/lemonbar/lemonbar-1.4.ebuild')
-rw-r--r--x11-misc/lemonbar/lemonbar-1.4.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/x11-misc/lemonbar/lemonbar-1.4.ebuild b/x11-misc/lemonbar/lemonbar-1.4.ebuild
new file mode 100644
index 0000000..ea45698
--- /dev/null
+++ b/x11-misc/lemonbar/lemonbar-1.4.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+if [[ ${PV} == *9999 ]]; then
+	inherit git-r3
+	EGIT_REPO_URI="https://github.com/LemonBoy/bar.git"
+fi
+
+DESCRIPTION="A featherweight, lemon-scented, bar based on xcb"
+HOMEPAGE="https://github.com/LemonBoy/bar"
+
+if [[ ${PV} == *9999 ]]; then
+	SRC_URI=""
+	KEYWORDS=""
+else
+	SRC_URI="https://github.com/LemonBoy/bar/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+	KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="+xft"
+
+DEPEND="x11-libs/libxcb
+	xft? ( x11-libs/libXft )
+"
+RDEPEND="${DEPEND}
+	dev-lang/perl
+"
+BDEPEND=""
+
+if [[ ${PV} != *9999 ]]; then
+	S="${WORKDIR}/bar-${PV}"
+fi

Consider giving Nix/NixOS a try! <3