summary refs log tree commit diff
path: root/x11-misc/pywal/pywal-3.3.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/pywal/pywal-3.3.0.ebuild')
-rw-r--r--x11-misc/pywal/pywal-3.3.0.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/x11-misc/pywal/pywal-3.3.0.ebuild b/x11-misc/pywal/pywal-3.3.0.ebuild
new file mode 100644
index 0000000..a8318c5
--- /dev/null
+++ b/x11-misc/pywal/pywal-3.3.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2018-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+if [[ ${PV} == *9999 ]]; then
+	SCM="git-r3"
+	EGIT_REPO_URI="https://github.com/dylanaraps/pywal.git"
+fi
+
+inherit distutils-r1 ${SCM}
+
+DESCRIPTION="Generate and change color-schemes on the fly."
+HOMEPAGE="https://github.com/dylanaraps/pywal"
+
+if [[ ${PV} == *9999 ]]; then
+	SRC_URI=""
+	KEYWORDS=""
+else
+	SRC_URI="https://github.com/dylanaraps/${PN}/archive/${PV}.tar.gz -> ${PV}.tar.gz"
+	KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}
+	media-gfx/imagemagick
+"
+BDEPEND=""

Consider giving Nix/NixOS a try! <3