summary refs log tree commit diff
path: root/x11-misc/xlocatemouse/xlocatemouse-20.05.ebuild
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--x11-misc/xlocatemouse/xlocatemouse-20.05.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/x11-misc/xlocatemouse/xlocatemouse-20.05.ebuild b/x11-misc/xlocatemouse/xlocatemouse-20.05.ebuild
new file mode 100644
index 0000000..af570a1
--- /dev/null
+++ b/x11-misc/xlocatemouse/xlocatemouse-20.05.ebuild
@@ -0,0 +1,37 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+if [[ ${PV} == *9999 ]]; then
+	inherit git-r3
+	EGIT_REPO_URI="https://www.uninformativ.de/git/xlocatemouse.git"
+fi
+
+DESCRIPTION="Find your X11 mouse pointer"
+HOMEPAGE="https://www.uninformativ.de/git/xlocatemouse/file/README.html"
+
+if [[ ${PV} == *9999 ]]; then
+	SRC_URI=""
+	KEYWORDS=""
+else
+	SRC_URI="https://www.uninformativ.de/git/xlocatemouse/archives/xlocatemouse-v${PV}.tar.gz -> ${PN}-v${PV}.tar.gz"
+	S="${WORKDIR}/${PN}-v${PV}"  # xlocatemouse-v20.05 is used in source tarball
+	KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+DEPEND="x11-libs/libX11"
+RDEPEND="${DEPEND}"
+BDEPEND=""
+
+PATCHES=(
+	"${FILESDIR}/${P}-makefile.patch"
+)
+
+src_install() {
+	emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" install
+}

Consider giving Nix/NixOS a try! <3