summary refs log tree commit diff
path: root/x11-misc/xlocatemouse/xlocatemouse-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/xlocatemouse/xlocatemouse-9999.ebuild')
-rw-r--r--x11-misc/xlocatemouse/xlocatemouse-9999.ebuild32
1 files changed, 23 insertions, 9 deletions
diff --git a/x11-misc/xlocatemouse/xlocatemouse-9999.ebuild b/x11-misc/xlocatemouse/xlocatemouse-9999.ebuild
index af570a1..cbd490e 100644
--- a/x11-misc/xlocatemouse/xlocatemouse-9999.ebuild
+++ b/x11-misc/xlocatemouse/xlocatemouse-9999.ebuild
@@ -1,13 +1,15 @@
-# Copyright 2021 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7
 
 if [[ ${PV} == *9999 ]]; then
-	inherit git-r3
+	SCM="git-r3"
 	EGIT_REPO_URI="https://www.uninformativ.de/git/xlocatemouse.git"
 fi
 
+inherit toolchain-funcs ${SCM}
+
 DESCRIPTION="Find your X11 mouse pointer"
 HOMEPAGE="https://www.uninformativ.de/git/xlocatemouse/file/README.html"
 
@@ -15,9 +17,9 @@ if [[ ${PV} == *9999 ]]; then
 	SRC_URI=""
 	KEYWORDS=""
 else
-	SRC_URI="https://www.uninformativ.de/git/xlocatemouse/archives/xlocatemouse-v${PV}.tar.gz -> ${PN}-v${PV}.tar.gz"
-	S="${WORKDIR}/${PN}-v${PV}"  # xlocatemouse-v20.05 is used in source tarball
+	SRC_URI="https://www.uninformativ.de/git/xlocatemouse/archives/xlocatemouse-v${PV}.tar.gz -> ${P}.tar.gz"
 	KEYWORDS="~amd64 ~x86"
+	S="${WORKDIR}/${PN}-v${PV}"
 fi
 
 LICENSE="MIT"
@@ -26,12 +28,24 @@ IUSE=""
 
 DEPEND="x11-libs/libX11"
 RDEPEND="${DEPEND}"
-BDEPEND=""
+BDEPEND="virtual/pkgconfig"
+
+DOCS=(CHANGES)
 
-PATCHES=(
-	"${FILESDIR}/${P}-makefile.patch"
-)
+src_prepare() {
+	default
+
+	sed -e 's/-O2 //g' -i Makefile || die
+}
+
+src_compile() {
+	emake CC="$(tc-getCC)"
+}
 
 src_install() {
-	emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" install
+	emake install \
+		DESTDIR="${D}" \
+		prefix="${EPREFIX}/usr"
+
+	einstalldocs
 }

Consider giving Nix/NixOS a try! <3