summary refs log tree commit diff
path: root/x11-misc/xob/xob-0.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/xob/xob-0.2.ebuild')
-rw-r--r--x11-misc/xob/xob-0.2.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/x11-misc/xob/xob-0.2.ebuild b/x11-misc/xob/xob-0.2.ebuild
new file mode 100644
index 0000000..a4d2502
--- /dev/null
+++ b/x11-misc/xob/xob-0.2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+if [[ ${PV} == *9999 ]]; then
+	inherit git-r3
+	EGIT_REPO_URI="https://github.com/florentc/xob.git"
+fi
+
+DESCRIPTION="A lightweight overlay volume (or anything) bar"
+HOMEPAGE="https://github.com/florentc/xob"
+
+if [[ ${PV} == *9999 ]]; then
+	SRC_URI=""
+	KEYWORDS=""
+else
+	SRC_URI="https://github.com/florentc/xob/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+	KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE=""
+
+DEPEND="
+	dev-libs/libconfig
+	x11-libs/libX11
+"
+RDEPEND="${DEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+DOCS=( README.md )
+
+src_install()
+{
+	emake install \
+		DESTDIR="${D}" \
+		prefix="${EPREFIX}/usr" \
+		sysconfdir="${EPREFIX}/etc"
+	einstalldocs
+}

Consider giving Nix/NixOS a try! <3