summary refs log tree commit diff
path: root/x11-wm/sdorfehs/sdorfehs-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--x11-wm/sdorfehs/sdorfehs-9999.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/x11-wm/sdorfehs/sdorfehs-9999.ebuild b/x11-wm/sdorfehs/sdorfehs-9999.ebuild
new file mode 100644
index 0000000..591bb39
--- /dev/null
+++ b/x11-wm/sdorfehs/sdorfehs-9999.ebuild
@@ -0,0 +1,48 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+if [[ ${PV} == *9999 ]]; then
+	SCM="git-r3"
+	EGIT_REPO_URI="https://github.com/jcs/sdorfehs.git"
+fi
+
+inherit savedconfig ${SCM}
+
+DESCRIPTION="Manual tiling window manager"
+HOMEPAGE="https://github.com/jcs/sdorfehs"
+
+if [[ ${PV} == *9999 ]]; then
+	SRC_URI=""
+	KEYWORDS=""
+else
+	SRC_URI="https://github.com/jcs/sdorfehs/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+	KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+DEPEND="
+	x11-libs/libX11
+	x11-libs/libXft
+	x11-libs/libXrandr
+	x11-libs/libXtst
+"
+RDEPEND="${DEPEND}"
+BDEPEND=""
+
+DOCS=( README.md )
+
+src_compile() {
+	restore_config config.h
+	default
+}
+
+src_install() {
+	save_config config.h
+	dobin ${PN}
+	doman ${PN}.1
+}

Consider giving Nix/NixOS a try! <3