summary refs log tree commit diff
path: root/x11-wm/shod/shod-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--x11-wm/shod/shod-9999.ebuild21
1 files changed, 15 insertions, 6 deletions
diff --git a/x11-wm/shod/shod-9999.ebuild b/x11-wm/shod/shod-9999.ebuild
index 106c12c..fd3f1ad 100644
--- a/x11-wm/shod/shod-9999.ebuild
+++ b/x11-wm/shod/shod-9999.ebuild
@@ -4,13 +4,11 @@
 EAPI=7
 
 if [[ ${PV} == *9999 ]]; then
-	SCM="git-r3"
+	inherit git-r3
 	EGIT_REPO_URI="https://github.com/phillbush/shod.git"
 fi
 
-inherit eutils ${SCM}
-
-DESCRIPTION="hybrid (floating and tiling) window manager"
+DESCRIPTION="Hybrid (floating and tiling) window manager"
 HOMEPAGE="https://github.com/phillbush/shod"
 
 if [[ ${PV} == *9999 ]]; then
@@ -25,12 +23,23 @@ LICENSE="MIT"
 SLOT="0"
 IUSE=""
 
-DEPEND="x11-libs/libX11
+DEPEND="
+	x11-libs/libX11
 	x11-libs/libXinerama
 "
 RDEPEND="${DEPEND}"
 BDEPEND=""
 
+src_prepare() {
+	sed -e '/^CPPFLAGS/d' \
+		-e 's/FLAGS =/FLAGS +=/g' \
+		-i config.mk || die
+
+	default
+}
+
 src_install() {
-	emake PREFIX= DESTDIR="${D}" MANPREFIX="/usr/share/man" install
+	emake install \
+		DESTDIR="${D}" \
+		PREFIX="${EPREFIX}/usr"
 }

Consider giving Nix/NixOS a try! <3