summary refs log tree commit diff
path: root/x11-wm/tinywm/tinywm-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'x11-wm/tinywm/tinywm-9999.ebuild')
-rw-r--r--x11-wm/tinywm/tinywm-9999.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/x11-wm/tinywm/tinywm-9999.ebuild b/x11-wm/tinywm/tinywm-9999.ebuild
new file mode 100644
index 0000000..551dce1
--- /dev/null
+++ b/x11-wm/tinywm/tinywm-9999.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2019-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+if [[ ${PV} == *9999 ]]; then
+	inherit git-r3
+	EGIT_REPO_URI="https://github.com/mackstann/tinywm.git"
+fi
+
+DESCRIPTION="The tiniest window manager."
+HOMEPAGE="https://github.com/mackstann/tinywm"
+
+if [[ ${PV} == *9999 ]]; then
+	SRC_URI=""
+	KEYWORDS=""
+else
+	SRC_URI="https://github.com/mackstann/tinywm/archive/${PV}.tar.gz -> ${P}.tar.gz"
+	KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="ISC"
+SLOT="0"
+IUSE=""
+
+DEPEND="x11-libs/libX11"
+RDEPEND="${DEPEND}"
+BDEPEND=""
+
+src_install() {
+	dobin ${PN}
+}

Consider giving Nix/NixOS a try! <3