about summary refs log tree commit diff
path: root/mail-client/tmpmail/tmpmail-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'mail-client/tmpmail/tmpmail-9999.ebuild')
-rw-r--r--mail-client/tmpmail/tmpmail-9999.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/mail-client/tmpmail/tmpmail-9999.ebuild b/mail-client/tmpmail/tmpmail-9999.ebuild
new file mode 100644
index 0000000..a5eb7b8
--- /dev/null
+++ b/mail-client/tmpmail/tmpmail-9999.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+if [[ ${PV} == *9999 ]]; then
+	inherit git-r3
+	EGIT_REPO_URI="https://github.com/sdushantha/tmpmail.git"
+fi
+
+if [[ ${PV} == *9999 ]]; then
+	SRC_URI=""
+	KEYWORDS=""
+else
+	SRC_URI="https://github.com/sdushantha/tmpmail/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+	KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="A temporary email right from your terminal written in POSIX sh"
+HOMEPAGE="https://github.com/sdushantha/tmpmail"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+	app-misc/jq
+	net-misc/curl[ssl]
+	www-client/w3m
+"
+DEPEND="${RDEPEND}"
+BDEPEND=""
+
+src_install() {
+	dobin ${PN}
+	doman ${PN}.1
+	dodoc README.md
+}

Consider giving Nix/NixOS a try! <3