summaryrefslogtreecommitdiff
path: root/configurations/ilmare/default.nix
diff options
context:
space:
mode:
authorAzat Bahawi <azat@bahawi.net>2024-08-03 00:23:38 +0300
committerAzat Bahawi <azat@bahawi.net>2024-08-03 00:23:38 +0300
commitffd1ac27a341de0da4bf63a5da1320ee6d132ae0 (patch)
tree721c614b649cea4b13f69a9983570247b7cef118 /configurations/ilmare/default.nix
parent908e945d148769bd627a25cd57a801acdde0c39c (diff)
2024-08-03
Diffstat (limited to 'configurations/ilmare/default.nix')
-rw-r--r--configurations/ilmare/default.nix24
1 files changed, 24 insertions, 0 deletions
diff --git a/configurations/ilmare/default.nix b/configurations/ilmare/default.nix
index 1e9f5ff..a1b5007 100644
--- a/configurations/ilmare/default.nix
+++ b/configurations/ilmare/default.nix
@@ -123,4 +123,28 @@ _: {
enable = true;
memoryPercent = 100;
};
+
+ nix = {
+ buildMachines = [
+ {
+ hostName = "eonwe.shire.net";
+
+ protocol = "ssh-ng";
+ sshUser = "builder";
+ sshKey = "/root/.ssh/id_ed25519";
+
+ system = "x86_64-linux";
+ supportedFeatures = [
+ "nixos-test"
+ "benchmark"
+ "big-parallel"
+ "kvm"
+ ];
+ }
+ ];
+
+ distributedBuilds = true;
+
+ settings.builders-use-substitutes = true;
+ };
}