summaryrefslogtreecommitdiff
path: root/configurations/manwe/default.nix
diff options
context:
space:
mode:
authorAzat Bahawi <azat@bahawi.net>2022-09-12 14:03:31 +0300
committerAzat Bahawi <azat@bahawi.net>2022-09-12 14:03:31 +0300
commit5b01fa945b2122b82da4be33203e4cf753951b7c (patch)
treef0693b31788e717d9ab1781cf19e2403727755df /configurations/manwe/default.nix
parent96ca9558928f4ffc9a99a94059fcd93d0a9de761 (diff)
2022-09-12
Diffstat (limited to 'configurations/manwe/default.nix')
-rw-r--r--configurations/manwe/default.nix75
1 files changed, 1 insertions, 74 deletions
diff --git a/configurations/manwe/default.nix b/configurations/manwe/default.nix
index 656667e..2599d78 100644
--- a/configurations/manwe/default.nix
+++ b/configurations/manwe/default.nix
@@ -1,6 +1,5 @@
{
config,
- inputs,
lib,
this,
...
@@ -11,8 +10,6 @@ with lib; {
./webserver.nix
];
- secrets.wireguard-private-key-manwe.file = "${inputs.self}/secrets/wireguard-private-key-manwe";
-
nixfiles.modules = {
nsd = {
enable = true;
@@ -20,10 +17,7 @@ with lib; {
};
unbound.enable = true;
- wireguard = {
- privateKeyFile = config.secrets.wireguard-private-key-manwe.path;
- server.enable = true;
- };
+ wireguard.server.enable = true;
acme.enable = true;
@@ -44,73 +38,6 @@ with lib; {
vaultwarden.enable = true;
};
- services.prometheus = {
- # TODO Make this generic.
- scrapeConfigs = with my.configurations;
- with config.services.prometheus.exporters; [
- {
- job_name = "endlessh-go";
- static_configs = [
- {
- targets = with config.services.endlessh-go.prometheus; [
- "${manwe.hostname}:${toString port}"
- "${varda.hostname}:${toString port}"
- "${yavanna.hostname}:${toString port}"
- ];
- }
- ];
- }
- {
- job_name = "nginx";
- static_configs = [
- {
- targets = with nginx; [
- "${manwe.hostname}:${toString port}"
- "${varda.hostname}:${toString port}"
- "${yavanna.hostname}:${toString port}"
- ];
- }
- ];
- }
- {
- job_name = "node";
- static_configs = [
- {
- targets = with node; [
- "${manwe.hostname}:${toString port}"
- "${varda.hostname}:${toString port}"
- "${yavanna.hostname}:${toString port}"
- ];
- }
- ];
- }
- {
- job_name = "postgres";
- static_configs = [
- {
- targets = with postgres; ["${manwe.hostname}:${toString port}"];
- }
- ];
- }
- {
- job_name = "unbound";
- static_configs = [
- {
- targets = with unbound; ["${manwe.hostname}:${toString port}"];
- }
- ];
- }
- {
- job_name = "wireguard";
- static_configs = [
- {
- targets = with wireguard; ["${manwe.hostname}:${toString port}"];
- }
- ];
- }
- ];
- };
-
networking = let
interface = "eth0";
in {