summaryrefslogtreecommitdiff
path: root/configurations/manwe/default.nix
diff options
context:
space:
mode:
authorAzat Bahawi <azat@bahawi.net>2022-12-17 16:39:09 +0300
committerAzat Bahawi <azat@bahawi.net>2022-12-17 16:39:09 +0300
commit8f137c28230623259a964484adcf31fe00756594 (patch)
tree82bce6a13fda125087cf6d9dc80aa91d9230d6c4 /configurations/manwe/default.nix
parent3229e56e0d3620ddc735edcfbbefb167efa3b23f (diff)
2022-12-17
Diffstat (limited to 'configurations/manwe/default.nix')
-rw-r--r--configurations/manwe/default.nix88
1 files changed, 0 insertions, 88 deletions
diff --git a/configurations/manwe/default.nix b/configurations/manwe/default.nix
deleted file mode 100644
index b8dd324..0000000
--- a/configurations/manwe/default.nix
+++ /dev/null
@@ -1,88 +0,0 @@
-{
- config,
- lib,
- this,
- ...
-}:
-with lib; {
- imports = [
- ./mailserver.nix
- ./webserver.nix
- ];
-
- nixfiles.modules = {
- nsd = {
- enable = true;
- fqdn = "ns1.${config.networking.domain}";
- };
- unbound.enable = true;
-
- wireguard.server.enable = true;
-
- acme.enable = true;
-
- monitoring.enable = true;
-
- postgresql.enable = true;
-
- git.server = {
- enable = true;
- domain = "git.${my.domain.azahi}";
- };
-
- gotify.enable = true;
- matrix.dendrite = {
- enable = true;
- domain = my.domain.azahi;
- };
- radicale.enable = true;
- rss-bridge.enable = true;
- shadowsocks.enable = true;
- soju = {
- enable = true;
- domain = my.domain.azahi;
- };
- vaultwarden.enable = true;
- };
-
- boot = {
- loader.grub = {
- enable = true;
- device = "/dev/sda";
- };
-
- initrd.availableKernelModules = [
- "ata_piix"
- "sd_mod"
- "sr_mod"
- "uhci_hcd"
- "virtio_pci"
- "virtio_scsi"
- ];
- };
-
- fileSystems = {
- "/boot" = {
- device = "/dev/sda1";
- fsType = "xfs";
- options = ["noatime"];
- };
-
- "/" = {
- device = "/dev/sda2";
- fsType = "xfs";
- options = ["noatime"];
- };
- };
-
- swapDevices = [
- {
- device = "/dev/sda3";
- }
- ];
-
- zramSwap = {
- enable = true;
- memoryPercent = 25;
- };
-}