summaryrefslogtreecommitdiff
path: root/configurations/melian/default.nix
diff options
context:
space:
mode:
authorAzat Bahawi <azat@bahawi.net>2022-09-16 15:13:19 +0300
committerAzat Bahawi <azat@bahawi.net>2022-09-16 15:13:19 +0300
commit751694df63b34946e1a79d379eac8c35ba40eed1 (patch)
treee1ac51c7ddca63c01c7042f84a0017dd8f75e5fb /configurations/melian/default.nix
parentd4a517f4b4ce067702248fdc944dca3f20df7791 (diff)
2022-09-16
Diffstat (limited to 'configurations/melian/default.nix')
-rw-r--r--configurations/melian/default.nix52
1 files changed, 10 insertions, 42 deletions
diff --git a/configurations/melian/default.nix b/configurations/melian/default.nix
index 08cbc8c..0aca218 100644
--- a/configurations/melian/default.nix
+++ b/configurations/melian/default.nix
@@ -66,15 +66,12 @@ with lib; {
};
boot = {
- kernelPackages = mkForce pkgs.linuxPackages_xanmod_latest;
-
- # Speeding Wi-Fi a bit.
+ # Speeding up Wi-Fi a bit.
extraModprobeConfig = ''
options iwlwifi 11n_disable=1
'';
initrd = {
- kernelModules = [];
availableKernelModules = ["ahci" "nvme" "sd_mod" "usb_storage" "usbhid" "xhci_pci"];
luks.devices."root" = {
@@ -83,7 +80,6 @@ with lib; {
bypassWorkqueues = true;
};
};
- kernelModules = ["kvm-intel"];
loader = {
efi.canTouchEfiVariables = true;
@@ -95,19 +91,10 @@ with lib; {
};
};
- hardware = {
- trackpoint = {
- enable = true;
- speed = 500;
- sensitivity = 250;
- };
-
- opengl.extraPackages = with pkgs; [
- intel-media-driver
- libvdpau-va-gl
- vaapiIntel
- vaapiVdpau
- ];
+ hardware.trackpoint = {
+ enable = true;
+ speed = 500;
+ sensitivity = 250;
};
powerManagement = let
@@ -127,31 +114,9 @@ with lib; {
};
services = {
- # No need for this anymore but it kept just in case.
- # tlp = {
- # enable = true;
- # settings = {
- # START_CHARGE_THRESH_BAT0 = 75;
- # STOP_CHARGE_THRESH_BAT0 = 80;
- # RESTORE_THRESHOLDS_ON_BAT = 1;
- # };
- # };
-
- throttled.enable = mkForce false;
-
thinkfan = {
enable = true;
- # Old-style configuration should be nullified because it does not support
- # hwmon search and appends to valid configuration resulting in conflicts
- # and crash. I probably should make a PR to remove what was introduced[1]
- # before.
- #
- # [1]: https://github.com/NixOS/nixpkgs/commit/02b872310d6a6503639f5a71a14f00441f961bc9
- sensors = mkForce null;
- fans = mkForce null;
- levels = mkForce null;
-
settings = {
sensors = [
{
@@ -161,10 +126,13 @@ with lib; {
}
];
fans = [{tpacpi = "/proc/acpi/ibm/fan";}];
- levels = [["level auto" 0 50] ["level disengaged" 50 32767]];
+ levels = [
+ ["level auto" 0 50]
+ ["level disengaged" 50 32767]
+ ];
};
};
- xserver.videoDrivers = ["intel" "modesetting"];
+ # xserver.videoDrivers = ["intel" "modesetting"];
};
}