summaryrefslogtreecommitdiff
path: root/configurations/varda/default.nix
diff options
context:
space:
mode:
authorAzat Bahawi <azat@bahawi.net>2024-05-01 03:36:55 +0300
committerAzat Bahawi <azat@bahawi.net>2024-05-01 03:36:55 +0300
commit9a20404924fda2587ce4f9769f75369799f34643 (patch)
treea953941a22d6c031e67b267e35a11db72bdd25e3 /configurations/varda/default.nix
parentc1353bb04b594a8b11fa7e28dbf29d0a6cb08275 (diff)
2024-05-01
Diffstat (limited to 'configurations/varda/default.nix')
-rw-r--r--configurations/varda/default.nix62
1 files changed, 62 insertions, 0 deletions
diff --git a/configurations/varda/default.nix b/configurations/varda/default.nix
new file mode 100644
index 0000000..c8ecef2
--- /dev/null
+++ b/configurations/varda/default.nix
@@ -0,0 +1,62 @@
+{ lib, ... }:
+with lib;
+{
+ imports = attrValues (modulesIn ./.);
+
+ nixfiles.modules = {
+ wireguard.client.enable = true;
+
+ acme.enable = true;
+
+ k3s.enable = true;
+ };
+
+ boot = {
+ loader = {
+ efi.canTouchEfiVariables = true;
+
+ systemd-boot = {
+ enable = true;
+ configurationLimit = 10;
+ };
+ };
+
+ initrd.availableKernelModules = [
+ "virtio_pci"
+ "virtio_scsi"
+ ];
+
+ # https://github.com/NixOS/nixpkgs/issues/89025
+ # https://forum.netcup.de/administration-of-a-server-vserver/vserver-server-kvm-server/p67571-icmpv6-ra-ndisc-router-discovery-failed-to-add-default-route/#post67571
+ # https://superuser.com/questions/33196/how-to-disable-autoconfiguration-on-ipv6-in-linux
+ kernel.sysctl = {
+ "net.ipv6.conf.all.autoconf" = 0;
+ "net.ipv6.conf.all.accept_ra" = 0;
+ };
+ };
+
+ fileSystems = {
+ "/" = {
+ device = "/dev/disk/by-uuid/b07e8273-915a-424c-8c55-cdc2bd482f49";
+ fsType = "xfs";
+ options = [ "noatime" ];
+ };
+
+ "/boot" = {
+ device = "/dev/disk/by-uuid/03FD-B6C0";
+ fsType = "vfat";
+ };
+ };
+
+ swapDevices = [
+ {
+ device = "/swapfile";
+ size = 4 * 1024;
+ }
+ ];
+
+ zramSwap = {
+ enable = true;
+ memoryPercent = 25;
+ };
+}