about summary refs log tree commit diff
path: root/flake.nix
diff options
context:
space:
mode:
authorazahi <azat@bahawi.net>2024-11-10 01:08:38 +0300
committerazahi <azat@bahawi.net>2024-11-10 01:08:38 +0300
commit693768ee37098dbebb38c86e27044f2faa38348d (patch)
tree37c92a1c83cf22fa5e5a570baa8598ba6063c795 /flake.nix
parent2024-10-29 (diff)
2024-11-10 HEAD master
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix9
1 files changed, 9 insertions, 0 deletions
diff --git a/flake.nix b/flake.nix
index c621f04..87ab0d0 100644
--- a/flake.nix
+++ b/flake.nix
@@ -32,6 +32,14 @@
       inputs.nixpkgs.follows = "nixpkgs";
     };
 
+    hyprland = {
+      url = "github:hyprwm/Hyprland";
+      inputs = {
+        # nixpkgs.follows = "nixpkgs"; # Disabled in favor of cache.
+        pre-commit-hooks.follows = "git-hooks";
+      };
+    };
+
     stylix = {
       url = "github:danth/stylix";
       inputs = {
@@ -193,6 +201,7 @@
         topology = self.topology.config.output;
 
         iso = self.nixosConfigurations.iso.config.system.build.isoImage;
+
         test-headless = self.nixosConfigurations.test-headless.config.system.build.vm;
         test-headful = self.nixosConfigurations.test-headful.config.system.build.vm;
       };

Consider giving Nix/NixOS a try! <3