summaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
authorAzat Bahawi <azat@bahawi.net>2023-06-17 13:21:03 +0300
committerAzat Bahawi <azat@bahawi.net>2023-06-17 13:21:03 +0300
commit2ed2b884c50f25bf757113c9630b12147d3f9b18 (patch)
treeec4cee94415390752857c3a5a3591c7e9f7be520 /flake.nix
parent2d4e9a5abfc08386250f42ba0f0c25ae63073d3e (diff)
2023-06-17
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix36
1 files changed, 30 insertions, 6 deletions
diff --git a/flake.nix b/flake.nix
index 3c87e85..ece18ad 100644
--- a/flake.nix
+++ b/flake.nix
@@ -92,10 +92,10 @@
repo = "arkenfox-nixos";
ref = "main";
inputs = {
- nixpkgs.follows = "nixpkgs";
flake-compat.follows = "flake-compat";
- pre-commit.follows = "pre-commit-hooks";
flake-utils.follows = "flake-utils";
+ nixpkgs.follows = "nixpkgs";
+ pre-commit.follows = "pre-commit-hooks";
};
};
@@ -106,8 +106,9 @@
repo = "nix-minecraft";
ref = "master";
inputs = {
- nixpkgs.follows = "nixpkgs";
+ flake-compat.follows = "flake-compat";
flake-utils.follows = "flake-utils";
+ nixpkgs.follows = "nixpkgs";
};
};
@@ -116,7 +117,12 @@
owner = "fn2006";
repo = "PollyMC";
ref = "7.0";
- inputs.nixpkgs.follows = "nixpkgs";
+ inputs = {
+ flake-compat.follows = "flake-compat";
+ flake-parts.follows = "flake-parts";
+ nixpkgs.follows = "nixpkgs";
+ pre-commit-hooks.follows = "pre-commit-hooks";
+ };
};
dns-nix = {
@@ -162,6 +168,14 @@
ref = "main";
};
+ flake-parts = {
+ type = "github";
+ owner = "hercules-ci";
+ repo = "flake-parts";
+ ref = "main";
+ inputs.nixpkgs-lib.follows = "nixpkgs";
+ };
+
flake-registry = {
type = "github";
owner = "NixOS";
@@ -176,8 +190,9 @@
repo = "agenix";
ref = "main";
inputs = {
- nixpkgs.follows = "nixpkgs";
darwin.follows = "darwin";
+ home-manager.follows = "home-manager";
+ nixpkgs.follows = "nixpkgs";
};
};
@@ -189,11 +204,20 @@
inputs = {
flake-compat.follows = "flake-compat";
flake-utils.follows = "flake-utils";
- nixpkgs.follows = "nixpkgs";
+ gitignore.follows = "gitignore";
nixpkgs-stable.follows = "nixpkgs-stable";
+ nixpkgs.follows = "nixpkgs";
};
};
+ gitignore = {
+ type = "github";
+ owner = "hercules-ci";
+ repo = "gitignore.nix";
+ ref = "master";
+ inputs.nixpkgs.follows = "nixpkgs";
+ };
+
xmonad-ng = {
# type = "path";
# path = "/home/azahi/src/xmonad-ng";