summaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
authorAzat Bahawi <azat@bahawi.net>2023-11-28 23:10:04 +0300
committerAzat Bahawi <azat@bahawi.net>2023-11-28 23:10:04 +0300
commit34f74229f8291156f35de943fbecfbe90c3366a9 (patch)
treee2c9e7f3897770ad849dacd947853d897b7183d7 /flake.nix
parent1b8d6874af2804424367c08c5f91e9566a8eb9c9 (diff)
2023-11-28
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix24
1 files changed, 5 insertions, 19 deletions
diff --git a/flake.nix b/flake.nix
index a70a934..e7a4624 100644
--- a/flake.nix
+++ b/flake.nix
@@ -41,13 +41,6 @@
ref = "master";
};
- nur = {
- type = "github";
- owner = "nix-community";
- repo = "NUR";
- ref = "master";
- };
-
darwin = {
type = "github";
owner = "LnL7";
@@ -194,20 +187,11 @@
inputs = {
flake-compat.follows = "flake-compat";
flake-utils.follows = "flake-utils";
- gitignore.follows = "gitignore";
nixpkgs-stable.follows = "nixpkgs-stable";
nixpkgs.follows = "nixpkgs";
};
};
- gitignore = {
- type = "github";
- owner = "hercules-ci";
- repo = "gitignore.nix";
- ref = "master";
- inputs.nixpkgs.follows = "nixpkgs";
- };
-
xmonad-ng = {
# type = "path";
# path = "/home/azahi/src/xmonad-ng";
@@ -269,9 +253,11 @@
overlays = [self.overlays.default];
};
- devShells.default = self.legacyPackages.${system}.mkShell {
- inherit (self.checks.${system}.preCommit) shellHook;
- };
+ devShells.default = with self.legacyPackages.${system};
+ mkShell {
+ inherit (self.checks.${system}.preCommit) shellHook;
+ packages = [go-task];
+ };
formatter = self.legacyPackages.${system}.alejandra;