summaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
authorAzat Bahawi <azat@bahawi.net>2024-05-25 22:16:47 +0300
committerAzat Bahawi <azat@bahawi.net>2024-05-25 22:16:47 +0300
commit364e8a98ad25127f2a51696ec03729e3a783044f (patch)
tree1ac46553d1dca1259da539eddc7db100eaf5c137 /flake.nix
parente2f999ec2a3dd7e9a52c7e2fadfe96976b5aee53 (diff)
2024-05-25
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix37
1 files changed, 29 insertions, 8 deletions
diff --git a/flake.nix b/flake.nix
index f0a1fc2..9e78601 100644
--- a/flake.nix
+++ b/flake.nix
@@ -8,7 +8,7 @@
inputs = {
nixpkgs.url = "github:NixOS/nixpkgs/nixpkgs-unstable";
nixpkgs-master.url = "github:NixOS/nixpkgs/master";
- nixpkgs-stable.url = "github:NixOS/nixpkgs/release-23.11";
+ nixpkgs-stable.url = "github:NixOS/nixpkgs/release-24.05";
nixos-hardware.url = "github:NixOS/nixos-hardware";
@@ -17,6 +17,11 @@
inputs.nixpkgs.follows = "nixpkgs";
};
+ srvos = {
+ url = "github:nix-community/srvos";
+ inputs.nixpkgs.follows = "nixpkgs";
+ };
+
stylix = {
url = "github:danth/stylix";
inputs = {
@@ -35,10 +40,21 @@
nixpkgs.follows = "nixpkgs";
};
};
+ # agenix-rekey = {
+ # url = "github:oddlama/agenix-rekey";
+ # inputs = {
+ # flake-utils.follows = "flake-utils";
+ # nixpkgs.follows = "nixpkgs";
+ # pre-commit-hooks.follows = "git-hooks";
+ # };
+ # };
dns = {
- url = "github:kirelagin/dns.nix";
- inputs.nixpkgs.follows = "nixpkgs";
+ url = "github:nix-community/dns.nix";
+ inputs = {
+ nixpkgs.follows = "nixpkgs";
+ flake-utils.follows = "flake-utils";
+ };
};
mailserver = {
@@ -53,6 +69,7 @@
url = "github:pinpox/alertmanager-ntfy";
inputs = {
flake-compat.follows = "flake-compat";
+ flake-utils.follows = "flake-utils";
nixpkgs.follows = "nixpkgs";
};
};
@@ -61,6 +78,7 @@
url = "github:nix-community/nix-vscode-extensions";
inputs = {
flake-compat.follows = "flake-compat";
+ flake-utils.follows = "flake-utils";
nixpkgs.follows = "nixpkgs";
};
};
@@ -69,6 +87,7 @@
url = "github:dwarfmaster/arkenfox-nixos";
inputs = {
flake-compat.follows = "flake-compat";
+ flake-utils.follows = "flake-utils";
nixpkgs.follows = "nixpkgs";
pre-commit.follows = "git-hooks";
};
@@ -78,6 +97,7 @@
url = "github:Infinidoge/nix-minecraft";
inputs = {
flake-compat.follows = "flake-compat";
+ flake-utils.follows = "flake-utils";
nixpkgs.follows = "nixpkgs";
};
};
@@ -91,6 +111,7 @@
url = "github:oddlama/nix-topology";
inputs = {
nixpkgs.follows = "nixpkgs";
+ flake-utils.follows = "flake-utils";
pre-commit-hooks.follows = "git-hooks";
};
};
@@ -101,7 +122,10 @@
xmonad-ng = {
url = "git+https://git.azahi.cc/xmonad-ng?ref=master";
- inputs.nixpkgs.follows = "nixpkgs";
+ inputs = {
+ nixpkgs.follows = "nixpkgs";
+ flake-utils.follows = "flake-utils";
+ };
};
azahi-cc = {
@@ -127,10 +151,7 @@
};
};
- flake-registry = {
- url = "github:NixOS/flake-registry";
- flake = false;
- };
+ flake-utils.url = "github:numtide/flake-utils";
flake-compat.url = "github:edolstra/flake-compat";
};