summaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
authorAzat Bahawi <azat@bahawi.net>2023-07-30 19:44:06 +0300
committerAzat Bahawi <azat@bahawi.net>2023-07-30 19:44:06 +0300
commit5834fee454d8fbe4d3eace6fa4d1f005cef0cbbb (patch)
treedb1f73878ab12627df270bc4bc998740da7f9728 /flake.nix
parent284d14147ab00f550be1777d5ec0f9ee36a04bd5 (diff)
2023-07-30
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix15
1 files changed, 14 insertions, 1 deletions
diff --git a/flake.nix b/flake.nix
index dd9473e..c76a436 100644
--- a/flake.nix
+++ b/flake.nix
@@ -74,6 +74,18 @@
ref = "master";
};
+ nixvim = {
+ type = "github";
+ owner = "nix-community";
+ repo = "nixvim";
+ ref = "main";
+ inputs = {
+ flake-utils.follows = "flake-utils";
+ nixpkgs.follows = "nixpkgs";
+ pre-commit-hooks.follows = "pre-commit-hooks";
+ };
+ };
+
nix-vscode-extensions = {
type = "github";
owner = "nix-community";
@@ -271,7 +283,8 @@
};
in {
packages = with lib;
- (mapAttrs (_: c: c.config.system.build.toplevel)
+ pkgs
+ // (mapAttrs (_: c: c.config.system.build.toplevel)
(builtins.removeAttrs self.nixosConfigurations ["iso-arm" "iso-x86"]))
// (let
buildIsoImage = name: self.nixosConfigurations.${name}.config.system.build.isoImage;