summaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
authorAzat Bahawi <azat@bahawi.net>2022-08-25 14:32:01 +0300
committerAzat Bahawi <azat@bahawi.net>2022-08-25 14:32:01 +0300
commit6ec5f8344117e6277bd225e6a178839f5648f36a (patch)
tree0735fee3417cb09174a536130bdaac47785a3d9c /flake.nix
parent63f085f0b035bee67254918c7b17bcc31984580c (diff)
2022-08-25
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix25
1 files changed, 25 insertions, 0 deletions
diff --git a/flake.nix b/flake.nix
index 4165cbe..d042cff 100644
--- a/flake.nix
+++ b/flake.nix
@@ -27,6 +27,7 @@
ref = "release-22.05";
};
+ # For testing PRs and stuff.
# nixpkgs-local = {
# type = "path";
# path = "/home/azahi/src/nixpkgs";
@@ -80,6 +81,17 @@
};
};
+ nix-minecraft-servers = {
+ type = "github";
+ owner = "jyooru";
+ repo = "nix-minecraft-servers";
+ ref = "main";
+ inputs = {
+ nixpkgs.follows = "nixpkgs";
+ utils.follows = "flake-utils-plus";
+ };
+ };
+
dns-nix = {
type = "github";
owner = "kirelagin";
@@ -121,6 +133,19 @@
inputs.nixpkgs.follows = "nixpkgs";
};
+ # NOTE Used indirectly by nix-minecraft-servers.
+ # This is declared explicitly because nested follows are broken[1].
+ #
+ # [1]: https://github.com/NixOS/nix/issues/5790
+ # [1]: https://github.com/NixOS/nix/pull/6621
+ flake-utils-plus = {
+ type = "github";
+ owner = "gytis-ivaskevicius";
+ repo = "flake-utils-plus";
+ ref = "master";
+ inputs.flake-utils.follows = "flake-utils";
+ };
+
flake-registry = {
type = "github";
owner = "NixOS";