about summary refs log tree commit diff
path: root/flake.nix
diff options
context:
space:
mode:
authorazahi <azat@bahawi.net>2025-01-14 13:27:50 +0300
committerazahi <azat@bahawi.net>2025-01-14 13:27:50 +0300
commitb8ea365ca8eb801f8c8442f2f9ab439343ed8b8f (patch)
treefe46f6e8f0da8d8525e486290cca3079679b363d /flake.nix
parent2025-01-06 (diff)
2025-01-14
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix15
1 files changed, 6 insertions, 9 deletions
diff --git a/flake.nix b/flake.nix
index 3bf2570..527ea3f 100644
--- a/flake.nix
+++ b/flake.nix
@@ -6,7 +6,7 @@
   #
   # [1]: https://github.com/NixOS/nix/issues/5373
   inputs = {
-    nixpkgs.url = "github:NixOS/nixpkgs?ref=1588cc08aff2ccae08ec49a0b8612ff71c5736ac";
+    nixpkgs.url = "github:NixOS/nixpkgs";
     nixpkgs-master.url = "github:NixOS/nixpkgs/master";
     nixpkgs-stable.url = "github:NixOS/nixpkgs/release-24.05";
 
@@ -154,7 +154,6 @@
       inputs = {
         flake-compat.follows = "flake-compat";
         nixpkgs.follows = "nixpkgs";
-        nixpkgs-stable.follows = "nixpkgs-stable";
       };
     };
 
@@ -165,7 +164,7 @@
   outputs =
     inputs@{ self, nixpkgs, ... }:
     let
-      lib = nixpkgs.lib.extend (lib: _: (import ./lib { inherit inputs lib system; }));
+      lib = nixpkgs.lib.extend (lib: _: import ./lib { inherit inputs lib system; });
 
       system = "x86_64-linux";
 
@@ -202,12 +201,10 @@
 
       overlays = import ./overlays.nix { inherit lib inputs; };
 
-      devShells.${system}.default =
-        with pkgs;
-        mkShell {
-          inherit (self.checks.${system}.git-hooks) shellHook;
-          packages = [ go-task ];
-        };
+      devShells.${system}.default = pkgs.mkShell {
+        inherit (self.checks.${system}.git-hooks) shellHook;
+        packages = [ pkgs.go-task ];
+      };
 
       formatter.${system} = pkgs.nixfmt;
 

Consider giving Nix/NixOS a try! <3