summaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
authorAzat Bahawi <azat@bahawi.net>2023-02-19 23:34:25 +0300
committerAzat Bahawi <azat@bahawi.net>2023-02-19 23:34:25 +0300
commitcc1d3db5f2a6f05ca68818dc2303dd85fc3db06d (patch)
tree6433af1654e8ae847990b26445b03fa9665aa674 /flake.nix
parent9e3f4268c87b0d1a64e9429ea173252a5f774ec5 (diff)
2023-02-19
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix6
1 files changed, 5 insertions, 1 deletions
diff --git a/flake.nix b/flake.nix
index 0563808..855913d 100644
--- a/flake.nix
+++ b/flake.nix
@@ -295,14 +295,18 @@
hooks = {
alejandra.enable = true;
deadnix.enable = true;
+ editorconfig-checker.enable = true;
prettier = {
enable = true;
- types = [];
files = "\\.css";
};
shellcheck.enable = true;
shfmt.enable = true;
statix.enable = true;
+ typos = {
+ enable = true;
+ types = ["text"];
+ };
};
settings.deadnix.edit = true;
};