summaryrefslogtreecommitdiff
path: root/modules/aria2.nix
diff options
context:
space:
mode:
authorAzat Bahawi <azat@bahawi.net>2024-04-21 02:15:42 +0300
committerAzat Bahawi <azat@bahawi.net>2024-04-21 02:15:42 +0300
commite6ed60548397627bf10f561f9438201dbba0a36e (patch)
treef9a84c5957d2cc4fcd148065ee9365a0c851ae1c /modules/aria2.nix
parent9ac64328603d44bd272175942d3ea3eaadcabd04 (diff)
2024-04-21
Diffstat (limited to 'modules/aria2.nix')
-rw-r--r--modules/aria2.nix33
1 files changed, 33 insertions, 0 deletions
diff --git a/modules/aria2.nix b/modules/aria2.nix
new file mode 100644
index 0000000..cdf1c4f
--- /dev/null
+++ b/modules/aria2.nix
@@ -0,0 +1,33 @@
+{ config, lib, ... }:
+with lib;
+let
+ cfg = config.nixfiles.modules.aria2;
+in
+{
+ options.nixfiles.modules.aria2.enable = mkEnableOption "aria2";
+
+ config = mkIf cfg.enable {
+ hm.programs.aria2 = {
+ enable = true;
+
+ settings = {
+ bt-max-peers = 128;
+ bt-save-metadata = true;
+ continue = true;
+ enable-dht = true;
+ enable-peer-exchange = true;
+ enable-rpc = false;
+ follow-torrent = true;
+ log-level = "info";
+ max-connection-per-server = 16;
+ max-overall-upload-limit = "1K";
+ max-tries = 5;
+ max-upload-limit = "1K";
+ seed-ratio = 0.1;
+ seed-time = 0.1;
+ stream-piece-selector = "default";
+ timeout = 60;
+ };
+ };
+ };
+}